読者です 読者をやめる 読者になる 読者になる

XAMPPな環境でmagento-1.5.1.0を入れると「PHP extension "curl" must be loaded.」と怒られる

Magento XAMPP PHP

まぁ、予想通りだったんですけどねー。ここを見ると、XAMPPをインストールしてコメントアウトを外せと書いてあったので、その通りにしましたw

php.iniの952行目あたりです。

; Windows Extensions
; Note that ODBC support is built in, so no dll is needed for it.
; Note that many DLL files are located in the extensions/ (PHP 4) ext/ (PHP 5)
; extension folders as well as the separate PECL DLL download (PHP 5).
; Be sure to appropriately set the extension_dir directive.

extension=php_bz2.dll
extension=php_curl.dll # <---REMOVE SEMICOLON HERE!!
;extension=php_dba.dll
extension=php_mbstring.dll
extension=php_exif.dll
;extension=php_fileinfo.dll
extension=php_gd2.dll

php.iniを編集したあとは

Apacheの再起動です↓

babydaemons@babydaemons-mobile /xampp/php
$ vi php.ini

babydaemons@babydaemons-mobile /xampp/php
$ net stop Apache2.2
Apache2.2 サービスを停止中です..
Apache2.2 サービスは正常に停止されました。


babydaemons@babydaemons-mobile /xampp/php
$ net start Apache2.2
Apache2.2 サービスを開始します......
Apache2.2 サービスは正常に開始されました。


babydaemons@babydaemons-mobile /xampp/php
$